using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=.*([!-~].*){8,})(?<=.*[a-z].*)(?<=.*[A-Z].*)(?<=.*[0-9].*)(?<=.*[!-/:-@\[-`{-~].*)$";
string input = @"(atC@t13
ecĂș r e P @ 5 s \ / \ /ord
Bad_password";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}