using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(((\D+\s)|(\d+\s))+)?(([4-8])|([4-8](\.|\,)([0-9])+))((\s?pol)|""|''|\x60|'|´|”)(?:.*)$";
string input = @"rom de as asd asd asd 444444 34234 6,5234234234polimeros (~ 64,3% relação tela-corpo)
(?:(?:(?:\D+\s)|(?:\d+\s))+)";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}