using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((0?[1-9]|[12][0-9]|3[01])(Jan|JAN|Mar|MAR|May|MAY|Jul|JUL|Aug|AUG|Oct|OCT|Dec|DEC)([0-9][0-9][0-9][0-9])|(0?[1-9]|[12][0-9]|30)(Apr|APR|Jun|JUN|Sep|SEP|Nov|NOV)([0-9][0-9][0-9][0-9])|(0?[1-9]|1[0-9]|2[0-8])(Feb|FEB)([0-9][0-9][0-9][0-9])|(29)(Feb|FEB)([0-9][0-9])([02468][048]|[13579][26]))$";
string input = @"1Jan2018 abcd
1Jan18
01Jan18
1Jan2018
01Jan2018
31Jan2018
31jan2018
31jAN2018
31JaN2018
31JAn2018
31JAN2018
28Feb2018
29Feb2018
29Feb2020
31Mar2018
30Apr2018
31Apr2018
31May2018
30Jun2018
31Jun2018
31Jul2018
31Aug2018
30Sep2018
31Sep2018
31Oct2018
30Nov2018
31Nov2018
31Dec2018";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}