# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(href|src|source|retinaSource|data)=([\"|'][^\"']*assets[^\"']*\.\w{1,5})(\?[^\"']*)?[\"|']"
test_str = ("<a href=\"javascript://\" class=\"btn btn-continue-operation disabled\">\n"
" <span>Continuar</span>\n"
" </a>\n\n"
"<a href='javascript://\" class=\"btn btn-continue-operation disabled'>\n"
" <span>Continuar</span>\n"
" </a>\n\n\n"
"<ul class=\"footer-legal l-adjacent-list\">\n"
" <li><a href=\"#external-content//genoma_transactional/cms_files/corporativo/seguridad-internet/index_transaccional.html\" class=\"footer-legal-element clr-gray.html\">{security}</a></li>\n"
" <li><a href='#external-content//genoma_transactional/cms_files/corporativo/sobre-ing/condiciones-servicio-tarifa_transaccional.html' class=\"footer-legal-element clr-gray\">{link-legal-info-footer}</a></li>\n"
"</ul>\n\n"
" <link type=\"text/css\" href=\" assets/custom-css /infobolsa \n\n\n"
".css\" rel=\"stylesheet\" media=\"all\" charset=\"utf-8\">\n\n"
" <div class=\"fingerprint-views-storage-content-img txt-c\">\n"
" {>pp-image imageId=\"fingerprint-activation\" altText=\"fingerprint-activation\"\n"
" source=\"assets/images/fingerprint-activation.png\"\n"
" retinaSource=\"assets/images/retina/fingerprint-activation@2x.png\"/}\n"
" </div>\n\n"
"<img src=\"modules/cc-menu/assets/images/logo_cc.svg\" alt=\"Components catalog\">\n\n"
"<img src=\"assets/images/twyp_cash_circle.svg?query=34\"> <img src=\"assets/ircle.svg?hgt=76\">\n\n"
"{>pp-image imageId=\"budgets-tutorial-client-step3\" altText=\"budget-tutorial-step3\"\n"
" source=\"components/budgets-tutorial/ASSETS/images/budgets-tutorial-client-step3.png\" {>pp-image imageId=\"budgets-tutorial-client-step3\" altText=\"budget-tutorial-step3\"\n"
" source=\"components/budgets-tutorial/ASSETS/images/budgets-tutorial-client-step3.png\"\n\n"
"{>pp-image source=\"assets/images/svg/logoING.svg\"/}\n\n"
" <div data-selector=\"logo-ing\" class=\"padding-top-sm padding-left-sm pull-left\">\n"
" <img id=\"logo\" src=\"assets/images/svg/logoING.svg\" class=\"img-svg svg-header-logo login-header\">\n"
" </div>\n\n"
" <audio data-selector=\"customer-connected-audio\">\n"
" <source src=\"modules/remote-advisor-agent/assets/audio/incomingCall.mp3\" type=\"audio/mp3\"/>\n"
" </audio>\n\n"
"<div class=\"col9\">\n"
" <div class=\"declaration-image-div\">{>pp-svg-image:no-products-other-bank imageId=\"declaration-image\" source=\"./assets/images/life-insurance-contract/cuestionario_riesgos.svg\"/}</div>\n"
" <p class=\"h5 clr-dark-gray lic-declaration-remark\">{lic-risk-declaration-remark|s}</p>\n"
" </div>\n\n"
" <div data-region-id=\"login-dnie-image\" class=\"login-dnie-image\"><img src=\"assets/images/dni-logo.png\"/></div>")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.