import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "P(\\d{1,}.\\d{1,}) (?<=)of(?= to)";
final String string = "You have paid P85.00 of GCash to Total NLEX Bonjour on 12-30-19 05:51:47 PM. Ref. No. 914311523.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}