package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\[.*?\])`)
var str = `'([Total Revenue] + [COGS] + [Distribution Costs] + [Sales Force Costs] + [A&P Costs] + [NDA Affairs Costs] + [Other Operating Costs]) * - [NDA share]'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}