re = /\?.*/m
str = '/geoinfo/weather/current/-83.442836,-214.974261?queryStringParameters=dddd&name1=sdasdas&queryStringParameters='
# Print the match result
str.scan(re) do |match|
puts match.to_s
end