import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*\\.(js\\?.*|js|otf|gif|png|jpg|svg|bmp|css|jpeg|pdf|ico|eot|woff|woff2|axd|ttf|gif\\?.*|png\\?.*|jpg\\?.*|svg\\?.*|bmp\\?.*|css\\?.*|jpeg\\?.*|pdf\\?.*|ico\\?.*|eot\\?.*|woff\\?.*|woff2\\?.*|axd\\?.*|ttf\\?.*|otf\\?.*)$";
final String string = "https://i.dell.com/sites/csimages/UberHomePage_Imagery/all/keyboard-mouse-icon.png";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}