import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?>\"\")(\\w*)";
final String string = "Sql.Database(\"GOULBDB42\", \"PALMSDB\", [Query=\"SELECT \"\"tblPOEOLicence\"\".\"\"InstrumentID\"\" as LicNo#(lf), \"\"tblClassification\"\".\"\"Description\"\" as Status#(lf), \"\"tblPOEOLicence\"\".\"\"AnniversaryDate\"\" as Anniv_date#(lf), \"\"tblLocation\"\".\"\"LocationName\"\" as Location#(lf), \"\"tblLGA\"\".\"\"Name\"\" as LicLGA#(lf), \"\"viewInstrumentAccountableParty\"\".\"\"APName\"\" as Licensee#(lf), \"\"tblActivityGroup\"\".\"\"Description\"\" as Schudeled_Activity#(lf), \"\"tblFeeBasedActivity\"\".\"\"Description\"\" as Fee_Based_Activity#(lf), \"\"tblPOEOLicenceFeeBasedActivity\"\".\"\"PrimaryFlag\"\" as PrimaryFBA#(lf), \"\"tblInstrument\"\".\"\"DateIssued\"\" as DateIssued#(lf), \"\"tblAddress\"\".\"\"Suburb\"\" as LocationSuburb#(lf), \"\"tblAddress\"\".\"\"StateCode\"\" as LocationState#(lf)FROM (((((((((((\"\"PALMSDB\"\".\"\"dbo\"\".\"\"tblPOEOLicence\"\" \"\"tblPOEOLicence\"\" INNER JOIN \"\"PALMSDB\"\".\"\"dbo\"\".\"\"tblInstrument\"\" \"\"tblInstrument\"\" ON \"\"tblPOEOLicence\"\".\"\"InstrumentID\"\"=\"\"tblInstrument\"\".\"\"InstrumentID\"\") INNER JOIN \"\"PALMSDB\"\".\"\"dbo\"\".\"\"tblPOEOLicenceFeeBasedActivity\"\" \"\"tblPOEOLicenceFeeBasedActivity\"\" ON \"\"tblPOEOLicence\"\".\"\"InstrumentID\"\"=\"\"tblPOEOLicenceFeeBasedActivity\"\".\"\"InstrumentID\"\") INNER JOIN \"\"PALMSDB\"\".\"\"dbo\"\".\"\"viewInstrumentAccountableParty\"\" \"\"viewInstrumentAccountableParty\"\" ON \"\"tblPOEOLicence\"\".\"\"InstrumentID\"\"=\"\"viewInstrumentAccountableParty\"\".\"\"InstrumentID\"\") INNER JOIN \"\"PALMSDB\"\".\"\"dbo\"\".\"\"tblInstrumentLocation\"\" \"\"tblInstrumentLocation\"\" ON \"\"tblPOEOLicence\"\".\"\"InstrumentID\"\"=\"\"tblInstrumentLocation\"\".\"\"InstrumentID\"\") INNER JOIN \"\"PALMSDB\"\".\"\"dbo\"\".\"\"tblLocation\"\" \"\"tblLocation\"\" ON \"\"tblInstrumentLocation\"\".\"\"LocationID\"\"=\"\"tblLocation\"\".\"\"LocationID\"\") INNER JOIN \"\"PALMSDB\"\".\"\"dbo\"\".\"\"tblLandTitle\"\" \"\"tblLandTitle\"\" ON \"\"tblLocation\"\".\"\"LocationID\"\"=\"\"tblLandTitle\"\".\"\"LocationID\"\") INNER JOIN \"\"PALMSDB\"\".\"\"dbo\"\".\"\"tblAddress\"\" \"\"tblAddress\"\" ON \"\"tblLocation\"\".\"\"AddressID\"\"=\"\"tblAddress\"\".\"\"AddressID\"\") LEFT OUTER JOIN \"\"PALMSDB\"\".\"\"dbo\"\".\"\"tblLandTitleLGA\"\" \"\"tblLandTitleLGA\"\" ON \"\"tblLandTitle\"\".\"\"LandTitleID\"\"=\"\"tblLandTitleLGA\"\".\"\"LandTitleID\"\") LEFT OUTER JOIN \"\"PALMSDB\"\".\"\"dbo\"\".\"\"tblLGA\"\" \"\"tblLGA\"\" ON \"\"tblLandTitleLGA\"\".\"\"LGAID\"\"=\"\"tblLGA\"\".\"\"LGAID\"\") INNER JOIN \"\"PALMSDB\"\".\"\"dbo\"\".\"\"tblFeeBasedActivity\"\" \"\"tblFeeBasedActivity\"\" ON \"\"tblPOEOLicenceFeeBasedActivity\"\".\"\"FeeBasedActivityID\"\"=\"\"tblFeeBasedActivity\"\".\"\"FeeBasedActivityID\"\") INNER JOIN \"\"PALMSDB\"\".\"\"dbo\"\".\"\"tblActivityGroup\"\" \"\"tblActivityGroup\"\" ON \"\"tblFeeBasedActivity\"\".\"\"ActivityGroupID\"\"=\"\"tblActivityGroup\"\".\"\"ActivityGroupID\"\") INNER JOIN \"\"PALMSDB\"\".\"\"dbo\"\".\"\"tblClassification\"\" \"\"tblClassification\"\" ON \"\"tblInstrument\"\".\"\"InstrumentStatusID\"\"=\"\"tblClassification\"\".\"\"ClassificationID\"\"#(lf)\"])";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}