#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)((([A-Za-z]{3,9}:(?:\/\/)?)(?:[-;:&=\+\$,\w]+@)?[A-Za-z0-9.-]+|(?:www.|[-;:&=\+\$,\w]+@)[A-Za-z0-9.-]+)(:[0-9]{0,5})?(#[\w]*)?((?:\/[\+~%\/.\w\-_]*)?\??(?:[-\+=&;%@.\w_]*)#?(?:[.\!\/\\w]*))?)"
Local $sString = "https://habibs.myportfolio.com" & @CRLF & _
"www.whatever.com" & @CRLF & _
"https://github.com/i-hate-regex" & @CRLF & _
"https://www.facebook.com/" & @CRLF & _
"https://www.google.com/" & @CRLF & _
"https://xkcd.com/2293/" & @CRLF & _
"http://www.example.com/" & @CRLF & _
"www.google.com" & @CRLF & _
"http://www.google.com" & @CRLF & _
"mailto:somebody@google.com" & @CRLF & _
"somebody@google.com" & @CRLF & _
"www.url-with-querystring.com/?url=has-querystring" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"https://this-shouldn't.match" & @CRLF & _
"and-this.df"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")