$re = '/[ ]+(corporation|\bcorp[.]*(?!\w))/mi';
$str = 'Corp
Corp,
Corporation
My Corp
My Corp.
My Corp. Company
My Corporation company
DRV Incorporation';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);