# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"repoType\":(.*?)\"repo\":(.*?),|\"resType\":(.*?),|\"result\":(.*?),|\"policy\":(.*?),|\"enforcer\":(.*?),|\"sess\":(.*?),|\"cliType\":(.*?),|\"reqData\":(.*?),|\"agentHost\":(.*?),|\"logType\":(.*?),|\"id\":(.*?),|\"seq_num\":(.*?),|\"event_count\":(.*?),|\"event_dur_ms\":(.*?),|\"tags\":(.*?),|\"additional_info\":|\"{(.)(?!$)"
test_str = ("{\"repoType\":3,\"repo\":\"DEV01_hive\",\"reqUser\":\"na230292\",\"evtTime\":\"2018-05-07 07:29:16.765\",\"access\":\"ALTER\",\"resource\":\"stg_hr_erp_hr_erpprod/hr_dm_application_groups\",\"resType\":\"@table\",\"action\":\"alter\",\"result\":1,\"policy\":695,\"enforcer\":\"ranger-acl\",\"sess\":\"ce536988-846d-47d2-a9dc-40e88c9c3e1a\",\"cliType\":\"HIVESERVER2\",\"cliIP\":\"149.25.76.150\",\"reqData\":\"msck repair table stg_hr_erp_hr_erpprod.hr_dm_application_groups\",\"agentHost\":\"rpc11743.corp.ncr.com\",\"logType\":\"RangerAudit\",\"id\":\"358f75d9-8423-49e1-bd3e-3cc795cccf2e-25620\",\"seq_num\":51241,\"event_count\":1,\"event_dur_ms\":0,\"tags\":[blah],\"additional_info\":\"{\\\"remote-ip-address\\\":149.25.76.150, \\\"forwarded-ip-addresses\\\":[]\",\"cluster_name\":\"DEV01\"}\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.