using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<id>\/f\/\d+\/\d+x\d+\/\w+\/[^\/]+)\/?(?<modifiers>m\/?(?<crop>\d+x\d+:\d+x\d+)?\/?(?<resize>(?<width>\-?\d+)x(?<height>\-?\d+))?\/?(?<filters>filters\:[^\/]+)?)?$";
string input = @"/f/39898/1000x600/d962430746/demo-image-human.jpeg/m/100x100:450x350/200x200/filters:grayscale()
/f/39898/2250x1500/c15735a73c/demo-image-human.jpeg/m/600x130
/f/39898/1000x600/d962430746/demo-image-human.jpeg/m/-230x230/filters:rotate(90)
/f/39898/1000x600/d962430746/demo-image-human.jpeg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}