# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"([^\/]+)\/?\n")
test_str = ("https://www.ducati.com/es/es/motocicletas/monster/monster-797\n"
"https://www.ducati.com/es/es/motocicletas/diavel/diavel-1260\n"
"https://www.ducati.com/es/es/motocicletas/hypermotard/hypermotard\n"
"https://www.ducati.com/es/es/motocicletas/hypermotard/hypermotard-950\n"
"https://www.ducati.com/es/es/motocicletas/monster/monster-1200\n"
"https://www.ducati.com/es/es/motocicletas/monster/monster-1200-25-anniversario\n"
"https://www.ducati.com/es/es/motocicletas/monster/monster-1200r\n"
"https://www.ducati.com/es/es/motocicletas/monster/monster-797\n"
"https://www.ducati.com/es/es/motocicletas/monster/monster-821\n"
"https://www.ducati.com/es/es/motocicletas/multistrada/multistrada-1260\n"
"https://www.ducati.com/es/es/motocicletas/multistrada/multistrada-1260-enduro\n"
"https://www.ducati.com/es/es/motocicletas/multistrada/multistrada-950\n"
"https://www.ducati.com/es/es/motocicletas/multistrada/multistrada-enduro\n"
"https://www.ducati.com/es/es/motocicletas/panigale/1299-panigale-r-final-edition\n"
"https://www.ducati.com/es/es/motocicletas/panigale/959-panigale\n"
"https://www.ducati.com/es/es/motocicletas/panigale/panigale-v4\n"
"https://www.ducati.com/es/es/motocicletas/panigale/panigale-v4-r\n"
"https://www.ducati.com/es/es/motocicletas/supersport/supersport\n"
"https://www.ducati.com/es/es/motocicletas/xdiavel/xdiavel\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.