package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{4}-\d{2}-\d{2}$`)
var str = `2018-01-01
01012018`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}