$re = '/[A-HJ-NP-TV-Z]{2}[\s-]{0,1}[0-9]{3}[\s-]{0,1}[A-HJ-NP-TV-Z]{2}|[0-9]{2,4}[\s-]{0,1}[A-Z]{1,3}[\s-]{0,1}[0-9]{2}/m';
$str = '## OLD FROMAT (complete) ##
3123 AA 11
3123-AA-11
3123AA11
8987 VG 33
8987VG33
## OLD FORMAT (with few characters) ##
31 F 11
## NEW FORMAT ##
AA 123 BB
AA-222-BB
DD345EE
AO 123 BB // O is excluded
AI-123-BB // I is excluded
AU123BB // U is exclided
AZ 123 BI
AZ-123-BU
AZ123BO';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);