$re = '/(?<=\"access_token\":\s\")[^\"]*/';
$str = '{"access_token": "D2L6O3vxWHlJasdlhsdflhvjODaBLD5HiJKd0y33Nt7LcVtp4S5phZ1-HvqHwn8qIB3TflApEluTvG09rO3M=", "scopes": "repository", "expires_in": 3600, "refresh_token": "ZfXk7JsdgESBZMuMHE", "token_type": "bearer"}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);