$re = '/(\w+)(\(⁰([\S\s]*?)\)⁰)?[.]?/m';
$str = 'auoeu ueu(⁰ueuou)⁰.bnthnh(⁰ueuou(u) + uooeu)⁰.c = ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);