re = /(MAIL\s+:)(([a-zA-Z0-9_\-\.]+)@([a-zA-Z0-9_\-\.]+)\.([a-zA-Z]{2,5}))\s+(([a-zA-Z0-9_\-\.]+)@([a-zA-Z0-9_\-\.]+)\.([a-zA-Z]{2,5}))/m
str = 'MAIL :alessandro.ottico@brt.it alessandro.ottico@gmail.com
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end