$re = '/(?<cRegexGroupsName>\d{9})/m';
$str = 'presentacion aeat 123456781 13122021';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);