#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(frente|contrafrente|fondo|interno)"
Local $sString = "Hermoso departamento 3 ambientes al frente , muy luminoso con vista panoramica . Cocina integrada , baño completo , balcon aterrazado vidriado con cerramientos . Agua caliente central , Abl: $ 276.-A 1 cuadra de Av. Rivadavia al 2600 y a 2 de Av. Pueyrredon , Subte A , Trenes , Ramales de Colectivos. A 2 cuadras del Shopping Spinetto. A pocas cuadras del Congreso de la Nación. .Información Adicional: Monto de las expensas: 1900Gas naturalGas naturalCaracterísticas y servicios del edificio: Agua corrienteElectricidadGas natural" & @CRLF & _
"ID: 221464"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")