use strict;
my $str = '1234test4321
4
0000oooo0000
4
Over!
1wat!
3
#23asd33
3
333asd3a
3
100dun2
3
Over!
';
my $regex = qr/(?<start>^[0-9]+)(?<message>[A-Za-z]+)(?<end>[^A-Za-z]*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}