#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(10|127|169\.254|192\.168|172\.(2[0-9]|1[6-9]|3[0-1])|(25[6-9]|2[6-9][0-9]|[3-9][0-9][0-9]|99[1-9]))\.)[0-9]{1,3}(\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)){3}$"
Local $sString = "Public ranges" & @CRLF & _
"1.0.0.0-9.255.255.255" & @CRLF & _
"11.0.0.0-100.63.255.255" & @CRLF & _
"100.128.0.0-126.255.255.255" & @CRLF & _
"128.0.0.0-169.253.255.255" & @CRLF & _
"169.255.0.0-172.15.255.255" & @CRLF & _
"172.32.0.0-191.255.255.255" & @CRLF & _
"192.0.1.0/24" & @CRLF & _
"192.0.3.0-192.88.98.255" & @CRLF & _
"192.88.100.0-192.167.255.255" & @CRLF & _
"192.169.0.0-198.17.255.255" & @CRLF & _
"198.20.0.0-198.51.99.255" & @CRLF & _
"198.51.101.0-203.0.112.255" & @CRLF & _
"203.0.114.0-223.255.255.255" & @CRLF & _
"" & @CRLF & _
"------OK------" & @CRLF & _
"1.1.1.1" & @CRLF & _
"9.255.255.255" & @CRLF & _
"11.0.0.0" & @CRLF & _
"126.255.255.255" & @CRLF & _
"128.0.0.0" & @CRLF & _
"169.253.255.255" & @CRLF & _
"169.255.0.0" & @CRLF & _
"172.15.255.255" & @CRLF & _
"172.32.0.0" & @CRLF & _
"192.167.255.255" & @CRLF & _
"192.169.0.0" & @CRLF & _
"" & @CRLF & _
"-----NOT OK-----" & @CRLF & _
"10.0.0.0" & @CRLF & _
"10.255.255.255" & @CRLF & _
"127.0.0.0" & @CRLF & _
"127.255.255.255" & @CRLF & _
"169.254.0.255" & @CRLF & _
"169.254.255.255" & @CRLF & _
"172.16.0.0" & @CRLF & _
"172.31.255.255" & @CRLF & _
"192.168.0.0" & @CRLF & _
"192.168.255.255" & @CRLF & _
"" & @CRLF & _
"Not including test nets" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")