re = /(20\d{2})-(0[1-9]|1[0-2])-([01][\d]|3[01])[\sT]([01]\d|2[0-3]):([0-5]\d):([0-5]\d)(Z|[\+-](0[\d]|1[\d]|2[0-3]):([0-5]\d))?/
str = '2023-01-01 00:00:00Z
2023-12-31 23:59:59+00:00
2023-06-06 13:47:23-06:00
2023-06-06T13:47:23+23:45
2023-06-06T13:47:23'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end