import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[\\(\\)eA-Z][a-z]*(?:_\\{? ?\\d*\\}?(?:(?:_\\d)?)*)?)+(?:\\^\\{? ?\\d*[\\+-]?\\}?)?";
final String string = "(NO_3)_{2} + (SO_4)_{21}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}