$re = '/[a-zA-Z]+\'[a-zA-Z]+?|[a-zA-Z]+/m';
$str = 'Hello my name is Cole. I can\'t believe this is really working
\'Let\'s try this now\'
!@#$%^&*()_+-=[]\\{}|;\':"`~,./<>?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);