package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"[^"]*"|(\+)`)
var str = `"inside", "", outside, "inside" 'inside' "'inside'" 'in\'side' "in\"side"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}