// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<i>(?<date>.*)|<p class="spits-[0-9]+">.*(?<intensity>[0-9]+)|<p>(?<description>[\w ,\.:'"]+)|<p class="spits-klasse">(?<default>[\w ,\.:'"]+)"#).unwrap();
let string = "<table width=\"100%\"><tr><td valign=\"top\" width=\"80\">
<b>wo 1 februari</b>
</td>
<td>
<table width=\"100%\"><tr class=\"spits-dagdeel spits-Ochtend\"><td valign=\"top\" width=\"60\">
<i>Ochtend</i>
</td>
<td>
<p class=\"spits-2\">lichte spits (2)
</p>
<p>De eerste dag van de nieuwe maand, woensdag. Tijdens de ochtend is het vaak rustig op de wegen en dat zal ook nu het geval zijn. We verwachten op het drukste moment niet meer dan 150 kilometer file op de snelwegen.</p>
<p class=\"spits-klasse\"> Bij een lichte spits wordt tot 150 km verwacht. De normale knelpunten hebben files.
</p>
</td>
</tr><tr class=\"spits-dagdeel spits-Avond\"><td valign=\"top\" width=\"60\">
<i>Avond</i>
</td>
<td>
<p class=\"spits-3\">reguliere spits (3)
</p>
<p>Deze spits iets meer drukte dan tijdens de ochtendspits, maar dat is vrij gebruikelijk. We verwachten geen bijzonderheden. Alleen bij ongelukken kunnen files snel in lengte toenemen.</p>
<p class=\"spits-klasse\"> Bij een reguliere spits wordt tot 225 km verwacht. Alle knelpunten hebben files.
</p>
</td>
</tr></table></td>
</tr></table>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}