# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\+55)?[\s]?\(?(\d{2})?\)?[\s-]?(9?\d{4}[\s-]?\d{4})$"
test_str = ("+55(16)91555-3456\n"
"22 98671 1032\n"
"+55 7134764819\n"
"(23)99378-4366\n"
"+5598683 1021\n"
"+551199603-3412\n"
"55 98214 9064\n"
"(55)98330-7156\n"
"(82) 936147156\n"
"+552430431084\n"
"2140028922\n"
"40028922\n"
"21 40028922\n"
"(21) 4002-8922\n"
"+55 21 4002 8922\n"
"+55(21)4002-8922\n"
"+55986320291")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.