import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Soft Offer Form - Speed Tool|Lead Gen - Enterprise Form|General Contact|Agency Partner Form|Content_Download|Soft Offer Form - Webinar Registrations|General Contact|Personal Contact)";
final String string = "Zendesk Web Widget\n"
+ "Scroll Depth\n"
+ "Demandbase\n"
+ "Campaign JULY3FREE\n"
+ "Personal Contact\n"
+ "Outbound Link\n"
+ "sites-copy\n"
+ "Google Optimize\n"
+ "sftp_user\n"
+ "add_install\n"
+ "backups\n"
+ "CTA - Above Fold\n"
+ "sites-new-create\n"
+ "page_performance\n"
+ "Phone\n"
+ "CTA - Top Nav\n"
+ "password_protect\n"
+ "Soft Offer Form - Speed Tool\n"
+ "Video\n"
+ "Soft Offer Form - Content Downloads\n"
+ "sites-new-copy\n"
+ "theme-demo\n"
+ "migration_checklist\n"
+ "General Contact\n"
+ "A/B Test\n"
+ "Buttons\n"
+ "wp-cli\n"
+ "account_user\n"
+ "Exit Intent Signup - Annual\n"
+ "portal_support\n"
+ "Account Name Suggestion\n"
+ "Lead\n"
+ "CTA - CTA Block\n"
+ "signup-gtm\n"
+ "hello-bar\n"
+ "signup\n"
+ "theme-download\n"
+ "signup_ecommerce\n"
+ "sites-convert-SE\n"
+ "Lead Gen - Enterprise Form\n"
+ "LiveChat\n"
+ "upgrade_plan\n"
+ "genesis-download\n"
+ "automated_migration\n"
+ "Agency Partner Form\n"
+ "undefined\n"
+ "sites-add-group\n"
+ "sites-edit-group\n"
+ "Lead Gen - Contact Us Form\n"
+ "sites-new-move\n"
+ "chat_window\n"
+ "ges-clicked\n"
+ "support-article-build-site\n"
+ "support-article-get-started\n"
+ "sites-move-SE\n"
+ "Content_Download\n"
+ "Opportunity\n"
+ "activity_log\n"
+ "Soft Offer Form - Webinar Registrations\n"
+ "ges-learn-more\n"
+ "studiopress-forum\n"
+ "studiopress-slack\n"
+ "studiopress-facebook\n"
+ "Scroll+Depth\n"
+ "Stick Metric\n"
+ "Bizzabo: WP Engine Summit 2019 Europe";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}