use strict;
my $str = 'https://www.chytryhonza.cz/hypoteka?utm_source=CeskeReality.cz&utm_medium=textovy_odkaz&utm_campaign=dis%7Chypo%7Caffiliate%7Ctextovy_odkaz&utm_content=nejvyhodnejsi_hypoteka&amount=1208648&property_price=1510810
https://www.chytryhonza.cz/hypoteka
';
my $regex = qr/\?.+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}