import Foundation
let pattern = #"web\.\d{1,}\s+\|\s+(\{|>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
10:50:46 AM web.2 | > creating redis session","time":"2016-05-18T17:50:46.161Z","v":0}
10:50:46 AM web.3 | {"name":"investor-webapp-registration","hostname":"lasinvonboard101-prod.tlcinternal.com","pid":28296,"level":20,"middleware":"cache-headers","msg":"Loading middleware:: cache-headers","time":"2016-05-18T17:50:46.172Z","v":0}
10:50:46 AM web.2 | {"name":"investor-webapp-registration","hostname":"lasinvonboard101-prod.tlcinternal.com","pid":28283,"level":40,"msg":"LC-SESSION: set the secret for the session cookies in the config file, check lc-session config","time":"2016-05-18T17:50:46.174Z","v":0}
10:50:46 AM web.3 | {"name":"investor-webapp-registration","hostname":"lasinvonboard101-prod.tlcinternal.com","pid":28296,"level":20,"middleware":"client-id","msg":"Loading middleware:: client-id","time":"2016-05-18T17:50:46.175Z","v":0}
10:50:46 AM web.3 | {"name":"investor-webapp-registration","hostname":"lasinvonboard101-prod.tlcinternal.com","pid":28296,"level":20,"middleware":"cookie-parser","msg":"Loading middleware:: cookie-parser","time":"2016-05-18T17:50:46.175Z","v":0}
10:50:46 AM web.3 | {"name":"investor-webapp-registration","hostname":"lasinvonboard101-prod.tlcinternal.com","pid":28296,"level":20,"middleware":"guid","msg":"Loading middleware:: guid","time":"2016-05-18T17:50:46.175Z","v":0}
10:50:46 AM web.3 | {"name":"investor-webapp-registration","hostname":"lasinvonboard101-prod.tlcinternal.com","pid":28296,"level":20,"middleware":"healthy","msg":"Loading middleware:: healthy","time":"2016-05-18T17:50:46.176Z","v":0}
10:50:46 AM web.2 | {"name":"investor-webapp-registration","hostname":"lasinvonboard101-prod.tlcinternal.com","pid":28283,"level":20,"middleware":"sso","msg":"Loading middleware:: sso","time":"2016-05-18T17:50:46.177Z","v":0}
10:50:46 AM web.2 | {"name":"investor-webapp-registration","hostname":"lasinvonboard101-prod.tlcinternal.com","pid":28283,"level":30,"msg":"SSO-MIDDLEWARE: Detecting SSO config","time":"2016-05-18T17:50:46.177Z","v":0}
10:50:46 AM web.2 | {"name":"investor-webapp-registration","hostname":"lasinvonboard101-prod.tlcinternal.com","pid":28283,"level":30,"msg":"SSO-MIDDLEWARE: enabling JANUS-SSO","time":"2016-05-18T17:50:46.179Z","v":0}
10:50:46 AM web.2 | {"name":"investor-webapp-registration","hostname":"lasinvonboard101-prod.tlcinternal.com","pid":28283,"level":20,"middleware":"timer","msg":"Loading middleware:: timer","time":"2016-05-18T17:50:46.180Z","v":0}
10:50:46 AM web.1 | {"name":"investor-webapp-registration","hostname":"lasinvonboard101-prod.tlcinternal.com","pid":28278,"level":20,"middleware":"cache-headers","msg":"Loading middleware:: cache-headers","time":"2016-05-18T17:50:46.180Z","v":0}
10:50:46 AM web.2 | {"name":"investor-webapp-registration","hostname":"lasinvonboard101-prod.tlcinternal.com","pid":28283,"level":20,"middleware":"setTrackingData","msg":"Loading middleware:: setTrackingData","time":"2016-05-18T17:50:46.181Z","v":0}
10:50:46 AM web.1 | {"name":"investor-webapp-registration","hostname":"lasinvonboard101-prod.tlcinternal.com","pid":28278,"level":20,"middleware":"client-id","msg":"Loading middleware:: client-id","time":"2016-05-18T17:50:46.181Z","v":0}
10:50:46 AM web.1 | {"name":"investor-webapp-registration","hostname":"lasinvonboard101-prod.tlcinternal.com","pid":28278,"level":20,"middleware":"cookie-parser","msg":"Loading middleware:: cookie-parser","time":"2016-05-18T17:50:46.181Z","v":0}
10:50:46 AM web.1 | {"name":"investor-webapp-registration","hostname":"lasinvonboard101-prod.tlcinternal.com","pid":28278,"level":20,"middleware":"guid","msg":"Loading middleware:: guid","time":"2016-05-18T17:50:46.181Z","v":0}
10:50:42 AM haproxy.1 | [WARNING] 138/105042 (28265) : Server nodes/node5001 is DOWN, reason: Layer4 connection problem, info: "Connection refused", check duration: 0ms. 2 active and 0 backup servers left. 0 sessions active, 0 requeued, 0 remaining in queue.
10:50:42 AM web.1 | warn: --minUptime not set. Defaulting to: 1000ms
10:50:42 AM web.1 | warn: --spinSleepTime not set. Your script will exit if it does not stay up for at least 1000ms
10:50:42 AM web.2 | warn: --minUptime not set. Defaulting to: 1000ms
10:50:42 AM web.2 | warn: --spinSleepTime not set. Your script will exit if it does not stay up for at least 1000ms
10:50:42 AM web.3 | warn: --minUptime not set. Defaulting to: 1000ms
10:50:42 AM web.3 | warn: --spinSleepTime not set. Your script will exit if it does not stay up for at least 1000ms
10:50:42 AM haproxy.1 | [WARNING] 138/105042 (28265) : Server nodes/node5002 is DOWN, reason: Layer4 connection problem, info: "Connection refused", check duration: 0ms. 1 active and 0 backup servers left. 0 sessions active, 0 requeued, 0 remaining in queue.
10:50:42 AM web.4 | warn: --minUptime not set. Defaulting to: 1000ms
10:50:42 AM web.4 | warn: --spinSleepTime not set. Your script will exit if it does not stay up for at least 1000ms
10:50:43 AM haproxy.1 | [WARNING] 138/105043 (28265) : Server nodes/node5003 is DOWN, reason: Layer4 connection problem, info: "Connection refused", check duration: 0ms. 0 active and 0 backup servers left. 0 sessions active, 0 requeued, 0 remaining in queue.
10:50:43 AM haproxy.1 | [ALERT] 138/105043 (28265) : backend 'nodes' has no server available!
10:50:43 AM web.2 | {"name":"investor-webapp-registration","hostname":"lasinvonboard101-prod.tlcinternal.com","pid":28283,"level":30,"msg":"starting server on port 5001","time":"2016-05-18T17:50:43.751Z","v":0}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)