using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^func (\(.*\) )?[a-zA-Z0-9]+?\((.*?)\) [a-zA-Z0-9 ]*?\{";
string input = @"func HelloWorld(name string) {
fmt.Println(name)
}
func HelloWorld() {
fmt.Println(""Hello World"")
}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}