using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(re)(?:gex)(\d+)";
string input = @"regex2017";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}