$re = '/RegEx/';
$str = 'Regex Regular Expressions RegExp RegEx';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);