# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"=\"?(?<currentValue>[^\"\n]*)\"? # renovate:(?:[\s]+datasource=[\"\']*(?<datasource>[^\s\"\']*)[\'\"]*|[\s]+depName=[\'\"]*(?<depName>[^\s\'\"]*)[\'\"]*|[\s]+registryUrl=[\'\"]*(?<registryUrl>[^\s\'\"]*)[\'\"]*|[\s]+versioning=[\'\"]*(?<versioning>[^\s\'\"]*)[\'\"]*|[\s]+extractVersion=[\'\"]*(?<extractVersion>[^\s\'\"]*)[\'\"]*)*"
test_str = ("# different prefix (shell scripts)\n"
"VERSION=0.1.0 # renovate: \n"
"DEP_VERSION=0.1.0 # renovate:\n\n"
"# different prefix (makefile)\n"
"VERSION?=0.1.0 # renovate:\n"
"DEP_VERSION:=0.1.0 # renovate:\n\n"
"# order does not matter\n"
"VERSION?=v1.28.0 # renovate: datasource=github-releases registryUrl=https://docker.io depName=adrienverge/yamllint versioning=semver extractVersion=example-v1.1.0\n"
"VERSION?=v1.28.0 # renovate: registryUrl=https://docker.io datasource=github-releases depName=adrienverge/yamllint versioning=semver extractVersion=example-v1.1.0\n"
"VERSION?=v1.28.0 # renovate: registryUrl=https://docker.io depName=adrienverge/yamllint datasource=github-releases versioning=semver extractVersion=example-v1.1.0\n"
"VERSION?=v1.28.0 # renovate: registryUrl=https://docker.io depName=adrienverge/yamllint versioning=semver datasource=github-releases extractVersion=example-v1.1.0\n"
"VERSION?=v1.28.0 # renovate: registryUrl=https://docker.io depName=adrienverge/yamllint versioning=semver extractVersion=example-v1.1.0 datasource=github-releases\n\n"
"# values can be wrapped between \" and '\n"
"VERSION?=v1.28.0 # renovate: datasource=\"github-releases\" registryUrl=\"https://docker.io\" depName=\"adrienverge/yamllint\" versioning=\"semver\" extractVersion=\"example-v1.1.0\"\n"
"VERSION?=v1.28.0 # renovate: datasource='github-releases' registryUrl='https://docker.io' depName='adrienverge/yamllint' versioning='semver' extractVersion='example-v1.1.0'\n\n"
"VERSION?=v1.28.0 # renovate: datasource=\"'\"\"'''\"github-releases\"'\"\"'''\" registryUrl=\"'\"\"'''\"https://docker.io\"'\"\"'''\" depName=\"'\"\"'''\"adrienverge/yamllint\"'\"\"'''\" versioning=\"'\"\"'''\"semver\"'\"\"'''\" extractVersion=\"'\"\"'''\"example-v1.1.0\"'\"\"'''\"\n\n"
"# ignore multiple spaces\n"
"VERSION?=v1.28.0 # renovate: datasource=github-releases registryUrl=https://docker.io depName=adrienverge/yamllint versioning=semver extractVersion=example-v1.1.0\n"
"VERSION?=v1.28.0 # renovate: registryUrl=https://docker.io datasource=github-releases depName=adrienverge/yamllint versioning=semver extractVersion=example-v1.1.0\n"
"VERSION?=v1.28.0 # renovate: registryUrl=https://docker.io depName=adrienverge/yamllint datasource=github-releases versioning=semver extractVersion=example-v1.1.0\n"
"VERSION?=v1.28.0 # renovate: registryUrl=https://docker.io depName=adrienverge/yamllint versioning=semver datasource=github-releases extractVersion=example-v1.1.0\n\n"
"VERSION?=v1.28.0 # renovate: registryUrl=https://docker.io depName=adrienverge/yamllint versioning=semver datasource=github-releases extractVersion=example-v1.1.0\n\n")
subst = "$datasource $registryUrl $depName"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.