#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.+)\=CellGet(.+)\(\'(.*)\'(.*)d_Plano, (\'.+\')"
Local $sString = "nAdesaoInformatica=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Adesão do contrato de informática (QUANTUM)');" & @CRLF & _
"nCarenciaDias=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Carência (dias)');" & @CRLF & _
"nComissaoVistaNovo=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Comissão à vista s/ valor novo (máximo 6%)');" & @CRLF & _
"nComissaoVistaRefin=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Comissão à vista s/ valor refinanciamento nas Lojas');" & @CRLF & _
"nComissaoProducao=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Comissão de Gestão da Produção');" & @CRLF & _
"nComissaoProRata=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Comissão pró rata temporis s/valor novo');" & @CRLF & _
"nComissaoTotal=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Comissão Total');" & @CRLF & _
"sConsignadoFederal=CellGetS ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Consignado Federal? (Sim/Não)');" & @CRLF & _
"nCustoEntidConsig=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Custo da Entidade Consignatária');" & @CRLF & _
"nCustoTedDoc=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Custo de TED/Vale Postal/DOC/OP');" & @CRLF & _
"nCustoPortalConsig=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Custo do portal de consignação');" & @CRLF & _
"nCustoCanalConsig=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Custo mensal de manutenção do canal de consignação');" & @CRLF & _
"nNumeroContratos=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Número de contratos');" & @CRLF & _
"nPerdaEsperada=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Perda Esperada (Outros)');" & @CRLF & _
"nProbabilidada=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Probabilidade liquidação antecipada (meses)');" & @CRLF & _
"nProderj=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'PRODERJ (Processamento de Dados)');" & @CRLF & _
"nProducao=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Produção em R$');" & @CRLF & _
"nProporcaoContratado=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Proporção do Valor Contratado');" & @CRLF & _
"nQuantidadePmt=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Quantidade de PMTs');" & @CRLF & _
"nRentabilidadeAcionista=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Rentabilidade mínima ao acionista (% a.a.)');" & @CRLF & _
"nSeguroPrestamista=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Seguro Prestamista');" & @CRLF & _
"nTaxa=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Taxa (a.m.)');" & @CRLF & _
"nZetrasoft=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Valor pago a Zetrasoft');" & @CRLF & _
"nValorContratado=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Valor Contratado');" & @CRLF & _
"nValorFinanciado=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Valor Financiado');" & @CRLF & _
"nFunding=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Funding (% DI)');" & @CRLF & _
"nCdi=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'CDI');" & @CRLF & _
"nCustoOportunidade=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Custo de oportunidade (CDI atual a.a.)');" & @CRLF & _
"nPisCofins=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'PIS/COFINS');" & @CRLF & _
"nIndiceBasileia=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Indice de Basiléia (médio)');" & @CRLF & _
"nValorNovo=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Valor Novo');" & @CRLF & _
"nValorRefinaciado=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Valor Refinanciado');" & @CRLF & _
"nPonderadorCapital=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Ponderador de capital');" & @CRLF & _
"sDataCurvaBmf=CellGetS ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Data Curva BM&F');" & @CRLF & _
"nIR=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Imposto de Renda');" & @CRLF & _
"nAtivosRisco=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Ativos ponderados pelo Risco');" & @CRLF & _
"nCapitalMinimoOp=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Capital mínimo exigido para a operação');" & @CRLF & _
"nResultadoLiqAcionista=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Resultado líquido mínimo exigido para atender ao acionista (a.a.)');" & @CRLF & _
"nResultadoBrutAcionista=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Resultado bruto mínimo exigido para atender ao acionista (antes do IR & CSLL) (a.a.)');" & @CRLF & _
"nTirMinimaAcionista=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'TIR mínima para remunerar o acionista');" & @CRLF & _
"nCustoFixoMensal=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Custo fixo mensal R$');" & @CRLF & _
"nCustoPmt=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Custo por PMT %');" & @CRLF & _
"nMultiplicadorRentab=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Multiplicador de rentabilidade');" & @CRLF & _
"nValorFaixaContratacao=CellGetN ('Premissas_Consolidado', d_Convenio, d_Canal_Originacao, d_Plano, 'Valor da Faixa de Contratação');"
Local $sSubst = "CellPut\2(\1, 'Premissas_Consolidado_Historico' \4sDescPlano, sVersao, \5"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)