$re = '`(?P<namespace>.+/)?(?P<image>[^:]+)(?P<tag>:.+)?`m';
$str = 'dsadasdas/docker/image:latest';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);