re = /^http(?:s)?:\/\/(?:www\.)?(?:[\w-]+?\.)?reddit.com(\/r\/|\/user\/)?(?(1)([\w:\.]{2,21}))(\/comments\/)?(?(3)(\w{5,9})(?:\/[\w%\\\\-]+)?)?(?(4)\/(\w{3,9}))?\/?(\?)?(?(6)(\S+))?(\#)?(?(8)(\S+))?$/m
str = 'https://www.reddit.com/r/WTF/comments/17j3sd/this_crawled_into_one_of_my_students_pool_and_she/c867wpi/#c867wpi
https://www.reddit.com/r/reddit.com/comments/17863/two_countries_one_booming_one_struggling_which/c13/
https://old.reddit.com/r/switcharoo/comments/u24xnc/bond_girl_vs_james_bond/j3g066i/
https://www.reddit.com/r/truetf2/comments/107nizk/what_makes_a_lot_of_the_configuration/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end