#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<url>https?://(?:(?:www|forums)\.aeva\.asn\.au/forums|forums\.aeva\.asn\.au)[^\s\"<]+)"
Local $sString = "Examples of URL patterns (cross linking the AEVA forum) that need conversion" & @CRLF & _
"============================================================================" & @CRLF & _
"" & @CRLF & _
"Thread ID: 756" & @CRLF & _
"http://www.aeva.asn.au/forums/forum_posts.asp?TID=132&KW=" & @CRLF & _
"" & @CRLF & _
"Thread ID: 1667" & @CRLF & _
"http://www.aeva.asn.au/forums/forum_posts.asp?TID=270" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Thread ID: 1959" & @CRLF & _
"http://www.aeva.asn.au/forums/forum_posts.asp?TID=316&PID=1958#1958" & @CRLF & _
"" & @CRLF & _
"Thread ID: 1427" & @CRLF & _
"http://www.aeva.asn.au/forums/forum_posts.asp?TID=65&KW=&PID=646#646" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Thread ID: 1997" & @CRLF & _
"http://www.aeva.asn.au/forums/forum_posts.asp?TID=161&PN=1" & @CRLF & _
"" & @CRLF & _
"Thread ID: " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Thread ID: " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Thread ID: " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Thread ID: " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Thread ID: " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Thread ID: " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Probably ignore these patterns, not many of them..." & @CRLF & _
"===================================================" & @CRLF & _
"Thread ID: 8573" & @CRLF & _
"<img src="http://www.aeva.asn.au/forums/smileys/smiley4.gif" border="0" />" & @CRLF & _
"" & @CRLF & _
"Thread ID: 4845" & @CRLF & _
"http://www.aeva.asn.au/forums/smileys/smiley18.gif" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Hi Andrew, " & @CRLF & _
"<br />I cant for the life of me see how to PM. Is it enabled?" & @CRLF & _
"<br />" & @CRLF & _
"<br />Anyway, here are the conversations I started that could be re-clasified if you get a chance." & @CRLF & _
"<br />" & @CRLF & _
"<br />Cheers," & @CRLF & _
"<br />Mal." & @CRLF & _
"<br />" & @CRLF & _
"<br />Media" & @CRLF & _
"<br />" & @CRLF & _
"<br />http://www.aeva.asn.au/forums/forum_posts.asp?TID=143&KW=" & @CRLF & _
"<br />" & @CRLF & _
"<br />" & @CRLF & _
"<br />Parts and Suppliers" & @CRLF & _
"<br />" & @CRLF & _
"<br />http://www.aeva.asn.au/forums/forum_posts.asp?TID=132&KW=" & @CRLF & _
"<br />http://www.aeva.asn.au/forums/forum_posts.asp?TID=128&KW=" & @CRLF & _
"<br />http://www.aeva.asn.au/forums/forum_posts.asp?TID=113&KW=" & @CRLF & _
"<br />http://www.aeva.asn.au/forums/forum_posts.asp?TID=116&KW="
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")