using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<a1>BARC)\|(?<a2>.{3})\|(?<a3>010)\|(?<a4>U7)\|(?<a5>[A-Z]{2}[0-9]{2})\|(?<a6>.{4})\|(?<a7>.{4})\|(?<a8>.)\|(?<a9>\d{10})\|(?<a10>[A-Z]{9})";
string input = @"BARC|P2E|010|U7|US50|USHC|L2XX|B|0058451938|XXXXXXXXX";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}