import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<href>(?<origin>(?<protocol>(?<scheme>[a-z][\\w\\-]{2,}):)?(?:\\/\\/)?)?(?:(?<username>[^:\\s]*):(?<password>[^@\\s]*)@)?(?<host>(?<hostname>\\B\\.{1,2}\\B(?=[a-z\\d]|\\/)|(?:[a-z][a-z-]*)(?:\\.[a-z][a-z-\\.]*|(?=\\/))|(?:[^\\s\\$]\\d[a-z\\d-]*)(?:\\.[a-z][a-z-\\.]*)|(?:(?:25[0-5]|(?:2[0-4]|1\\d|[1-9]|)\\d)(?:\\.(?!$)|$)){4}|localhost)(?:\\:(?<port>\\d+))?)(?<pathname>\\/[^?#\\s]*)?(?<search>\\?[^#\\s]*)?(?<hash>#[^\\s]*)?)";
final String string = "https://user:pass@api.twitch.tv:8080/Kshipa?popout=true#unload";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}