package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]+$`)
var str = `sdfsdf
s223
1212
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}