re = /\b[A-Z0-9._%+-]+@[A-Z0-9.-]+\.[A-Z]{2,}\b/i
str = 'krzyszof.jassem@amu.edu.pl'
# Print the match result
str.match(re) do |match|
puts match.to_s
end