import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\+\\d{1,3}|\\d{1,3})?\\s?(\\(\\d{2}\\)|\\d{2})?\\d{4,5}-\\d{4}";
final String string = "- (11)98756-1212\n"
+ "- 98765-4321\n"
+ "-+55 (11)94362-3708\n"
+ "- 97333-3723\n"
+ "- 98733-4344\n"
+ "- (11)97283-3849\n"
+ "1196377-3243";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}