import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<Name>\\w+)\\s\\w+\\s(?<Major>\\*|\\d+)\\.?(?<Minor>\\*|\\d+)?\\.?(?<Patch>\\*|\\d+)?";
final String string = "Android OS 5.1 / API (LYZ28N/500200305)\n"
+ "Android OS 5.1.1 / API (LYZ28N/500200305)\n"
+ "Android OS 10 / API-29 (LYZ28N/500200305)\n"
+ "Android OS 102222.1323121312 / API-29 (LYZ28N/500200305)\n"
+ "iPhone OS 5.12 / API (LYZ28N/500200305)\n"
+ "iPhone OS 5 / API (LYZ28N/500200305)\n"
+ "iPhone OS 5.1.10000.1.1.1.1.1.1.1.1 / API (LYZ28N/500200305)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}