const regex = /(?P<cdn_node_ip>\S+) - (?P<client_ip>\S+) - - \[(?P<date>\S+)\] "(?P<verb>\w+) (?P<url>\/(?P<delivery_type_code>\S+?)\/(?P<delivery_type>\S+?)\/(?P<bucket_id>\S+?)\/(?P<file_path>.*)) (?P<version>\S+) (?P<referrer_url>\S+)" (?P<status_code>\d+) (?P<content_length>\d+) (?P<bytes_transferred>\d+) (?P<duration>\d+) (?P<cached>-|\d+) "(?P<user_agent>.*?)" "(?P<ep_region_id>\d+) (?P<user_region_id>\d+) (?P<ep_pid>\d+) (?P<user_pid>\d+) (?P<hash_content>\S+)" "("|(?P<download_id>\d+) (?P<origin>\S+) (?P<retries>\d+) (?P<code>\d+) (?P<time>\d+) (?P<p2p>\d+)") (?P<host>\S+) (?P<request_id>\d+) (?P<http_request>\d+) (?P<cache_tier_name>\S+) (?P<layer>\d)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<cdn_node_ip>\\S+) - (?P<client_ip>\\S+) - - \\[(?P<date>\\S+)\\] "(?P<verb>\\w+) (?P<url>\\\/(?P<delivery_type_code>\\S+?)\\\/(?P<delivery_type>\\S+?)\\\/(?P<bucket_id>\\S+?)\\\/(?P<file_path>.*)) (?P<version>\\S+) (?P<referrer_url>\\S+)" (?P<status_code>\\d+) (?P<content_length>\\d+) (?P<bytes_transferred>\\d+) (?P<duration>\\d+) (?P<cached>-|\\d+) "(?P<user_agent>.*?)" "(?P<ep_region_id>\\d+) (?P<user_region_id>\\d+) (?P<ep_pid>\\d+) (?P<user_pid>\\d+) (?P<hash_content>\\S+)" "("|(?P<download_id>\\d+) (?P<origin>\\S+) (?P<retries>\\d+) (?P<code>\\d+) (?P<time>\\d+) (?P<p2p>\\d+)") (?P<host>\\S+) (?P<request_id>\\d+) (?P<http_request>\\d+) (?P<cache_tier_name>\\S+) (?P<layer>\\d)', 'g')
const str = `10.95.151.28 - 10.95.151.253 - - [22/Jan/2019:10:41:45.956] "GET /P/0/_53/video_68473.fakevideo HTTP/1.1 -" 404 42 42 4019 - "curl/7.29.0" "1 2 1 2 03" "" b53.1.qacdndev.cdn.hi.inet 3 0 hdd 0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}