re = /(?<=id=)(.*)(?=} Task)/m
str = '[2022-11-05 00:37:34,687] ERROR WorkerSourceTask{id=log_events-0} Task is being killed and will not recover until manually restarted (org.apache.kafka.connect.runtime.WorkerTask:187)
[2022-11-05 00:47:46,495] ERROR WorkerSourceTask{id=log_map-0} Task is being killed and will not recover until manually restarted (org.apache.kafka.connect.runtime.WorkerTask:187)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end