import Foundation
let pattern = #"https:\/\/[a-z\.]+.kaspersky-labs\.com\/[0-9A-Z\-]+\/main\.js"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"https://gc.kis.scr.kaspersky-labs.com/3AB9A552-5B01-8648-A873-82DD69063EB6/main.js"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)