using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|;)(?:sp|tr)\|([a-zA-Z0-9_-]+)\|\S+?(?=$|;)";
string input = @"sp|A8MXV4|NUD19_HUMAN;sp|A8MXV4|NUD19_HUMAN";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}